Monday, October 11, 2010

Ubuntu directions for installing Linux on USB through OSX

Note: this procedure requires an .img file that you will be required to create from the .iso file you download.
TIP: Drag and Drop a file from Finder to Terminal to 'paste' the full path without typing and risking type errors.
1. Download the desired file
2. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
3. Convert the .iso file to .img using the convert option of hdiutil (e.g.,hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso)
4. Note: OS X tends to put the .dmg ending on the output file automatically.
5. Run diskutil list to get the current list of devices
6. Insert your flash media
7. Run diskutil list again and determine the device node assigned to your flash media (e.g. /dev/disk2)
8. Run diskutil unmountDisk /dev/diskN (replace N with the disk number from the last command; in the previous example, N would be 2)
9. Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.imgor ./ubuntu.dmg).
Using /dev/rdisk instead of /dev/disk may be faster.
If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M.
If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive.
10. Run diskutil eject/dev/diskN and remove your flash media when the command completes
11. Restart your Mac and press alt while the Mac is restarting to choose the USB-Stick